Runtimes

Runtime environments for deploying Lolo Applications

Overview

Lolo Applications are deployed onto a Supported Kubernetes infrastructure that has been prepared for as a Lolo Runtime.

Supported Kubernetes versions

Lolo supports the following Kubernetes versions and infrastructure providers.
The Kubernetes community releases minor versions roughly every three months. Recently the Kubernetes community has increased the window of support for each version from 9 months to 12 months, starting with version 1.19. Lolo can continue to run in a Kubernetes cluster version that has reached end of support, however it is recommended to upgrade clusters to newer versions before the Kubernetes end of support is reached.

Cloud / Infrastructure Provider

Supported Versions

Comments

Google Cloud Platform (GCP)

Kubernetes (GKE) 1.16
Kubernetes (GKE) 1.17
Kubernetes (GKE) 1.18

1.16 Kubernetes end of support January 29 2021

Amazon Webservices (AWS)

Kubernetes (EKS) 1.16
Kubernetes (EKS) 1.17
Kubernetes (EKS) 1.18

EKS 1.16 end of support July 2021

Microsoft Azure (Azure)

Kubernetes (AKS) 1.16
Kubernetes (AKS) 1.17
Kubernetes (AKS) 1.18

AKS 1.16 end of support January 29 2021

On Premise

Kubernetes 1.16
Kubernetes 1.17
Kubernetes 1.18


What’s Next